What’s Vulnerable › Vulnerabilities
CVE-2008-2364
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-06-13 · updated 2026-06-16
- Weakness: CWE-770
Description
The ap_proxy_http_process_response function in mod_proxy_http.c in the mod_proxy module in the Apache HTTP Server 2.0.63 and 2.2.8 does not limit the number of forwarded interim responses, which allows remote HTTP servers to cause a denial of service (memory consumption) via a large number of interim responses.
Affected products
- Apache HTTP Server: from 2.0.35 before 2.0.64; from 2.2.0 before 2.2.9 — fixed in 2.0.64, 2.2.9
- Canonical Ubuntu Linux: 6.06, 7.10, 8.04
- Fedoraproject Fedora: 8, 9
- RedHat Enterprise Linux Desktop: 3.0, 4.0, 5.0
- RedHat Enterprise Linux Eus: 4.7, 5.2
- RedHat Enterprise Linux Server: 3.0, 4.0, 5.0
- RedHat Enterprise Linux Workstation: 3.0, 4.0, 5.0
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.0.64, 2.2.9. Check the vendor advisory for mitigations.
References
- http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c01539432
- http://lists.apple.com/archives/security-announce/2008/Oct/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00004.html
- http://marc.info/?l=bugtraq&m=123376588623823&w=2
- http://marc.info/?l=bugtraq&m=125631037611762&w=2
- http://rhn.redhat.com/errata/RHSA-2008-0967.html
- http://secunia.com/advisories/30621
- http://secunia.com/advisories/31026
- http://secunia.com/advisories/31404
- http://secunia.com/advisories/31416
- http://secunia.com/advisories/31651
Get alerted when CVE-2008-2364 or the next vulnerability affects your stack