What’s Vulnerable › Vulnerabilities
CVE-2008-2374
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-07-07 · updated 2026-06-16
- Weakness: CWE-1284
Description
src/sdp.c in bluez-libs 3.30 in BlueZ, and other bluez-libs before 3.34 and bluez-utils before 3.34 versions, does not validate string length fields in SDP packets, which allows remote SDP servers to cause a denial of service or possibly have unspecified other impact via a crafted length field that triggers excessive memory allocation or a buffer over-read.
Affected products
- Bluez-Libs: before 3.34 — fixed in 3.34
- Bluez-Utils: before 3.34 — fixed in 3.34
- Fedoraproject Fedora: 8, 9
How to fix
Upgrade to a fixed version: Bluez-Libs 3.34; Bluez-Utils 3.34. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2008-09/msg00005.html
- http://secunia.com/advisories/30957
- http://secunia.com/advisories/31057
- http://secunia.com/advisories/31833
- http://secunia.com/advisories/32099
- http://secunia.com/advisories/32279
- http://secunia.com/advisories/34280
- http://security.gentoo.org/glsa/glsa-200903-29.xml
- http://sourceforge.net/mailarchive/message.php?msg_name=b32d44000806161327u680c290au54fd21f2fef1d58e%40mail.gmail.com
- http://www.bluez.org/bluez-334/
- http://www.mandriva.com/security/advisories?name=MDVSA-2008:145
- http://www.redhat.com/support/errata/RHSA-2008-0581.html
Get alerted when CVE-2008-2374 or the next vulnerability affects your stack