What’s Vulnerable › Vulnerabilities
CVE-2008-2540
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-06-03 · updated 2026-06-16
- Weakness: CWE-264
Description
Apple Safari on Mac OS X, and before 3.1.2 on Windows, does not prompt the user before downloading an object that has an unrecognized content type, which allows remote attackers to place malware into the (1) Desktop directory on Windows or (2) Downloads directory on Mac OS X, and subsequently allows remote attackers to execute arbitrary code on Windows by leveraging an untrusted search path vulnerability in (a) Internet Explorer 7 on Windows XP or (b) the SearchPath function in Windows XP, Vista, and Server 2003 and 2008, aka a "Carpet Bomb" and a "Blended Threat Elevation of Privilege Vulnerability," a different issue than CVE-2008-1032. NOTE: Apple considers this a vulnerability only because the Microsoft products can load application libraries from the desktop and, as of 20080619, has not covered the issue in an advisory for Mac OS X.
Affected products
- Apple Safari: before 3.1.2 — fixed in 3.1.2
How to fix
Upgrade to a fixed version: Apple Safari 3.1.2. Check the vendor advisory for mitigations.
References
- http://aviv.raffon.net/2008/05/31/SafariPwnsInternetExplorer.aspx
- http://blogs.zdnet.com/security/?p=1230
- http://lists.apple.com/archives/security-announce/2008//Jun/msg00001.html
- http://secunia.com/advisories/30467
- http://securitytracker.com/id?1020150
- http://support.avaya.com/elmodocs2/security/ASA-2009-133.htm
- http://support.nortel.com/go/main.jsp?cscat=BLTNDETAIL&id=871138
- http://www.dhanjani.com/archives/2008/05/safari_carpet_bomb.html
- http://www.microsoft.com/technet/security/advisory/953818.mspx
- http://www.securityfocus.com/bid/29445
- http://www.securitytracker.com/id?1022047
- http://www.us-cert.gov/cas/techalerts/TA09-104A.html
Get alerted when CVE-2008-2540 or the next vulnerability affects your stack