What’s Vulnerable › Vulnerabilities

CVE-2008-2664

Description

The rb_str_format function in Ruby 1.8.4 and earlier, 1.8.5 before 1.8.5-p231, 1.8.6 before 1.8.6-p230, 1.8.7 before 1.8.7-p22, and 1.9.0 before 1.9.0-2 allows context-dependent attackers to trigger memory corruption via unspecified vectors related to alloca, a different issue than CVE-2008-2662, CVE-2008-2663, and CVE-2008-2725. NOTE: as of 20080624, there has been inconsistent usage of multiple CVE identifiers related to Ruby. The CVE description should be regarded as authoritative, although it is likely to change.

Affected products

How to fix

Upgrade to a fixed version: Ruby 1.8.5.231, 1.8.6.230, 1.8.7.22, 1.9.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-2664 or the next vulnerability affects your stack