What’s Vulnerable › Vulnerabilities

CVE-2008-2726

Description

Integer overflow in the (1) rb_ary_splice function in Ruby 1.8.4 and earlier, 1.8.5 before 1.8.5-p231, 1.8.6 before 1.8.6-p230, 1.8.7 before 1.8.7-p22, and 1.9.0 before 1.9.0-2; and (2) the rb_ary_replace function in 1.6.x allows context-dependent attackers to trigger memory corruption, aka the "beg + rlen" issue. NOTE: as of 20080624, there has been inconsistent usage of multiple CVE identifiers related to Ruby. The CVE description should be regarded as authoritative, although it is likely to change.

Affected products

How to fix

Upgrade to a fixed version: Ruby 1.8.5.231, 1.8.6.230, 1.8.7.22, 1.9.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-2726 or the next vulnerability affects your stack