What’s Vulnerable › Vulnerabilities
CVE-2008-2931
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-07-09 · updated 2026-06-16
- Weakness: CWE-269
Description
The do_change_type function in fs/namespace.c in the Linux kernel before 2.6.22 does not verify that the caller has the CAP_SYS_ADMIN capability, which allows local users to gain privileges or cause a denial of service by modifying the properties of a mountpoint.
Affected products
- Canonical Ubuntu Linux: 6.06, 7.04, 7.10, 8.04
- Debian Linux: 4.0
- Linux kernel: before 2.6.22 — fixed in 2.6.22
- Novell Suse Linux Enterprise Desktop: 10.0-sp1, 10.0-sp2
- Novell Suse Linux Enterprise Server: 10.0-sp1, 10.0-sp2
- Opensuse: from 10.3 through 11.0
How to fix
Upgrade to a fixed version: Linux kernel 2.6.22. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commitdiff%3Bh=ee6f958291e2a768fd727e7a67badfff0b67711a
- http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.22
- http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00007.html
- http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00001.html
- http://secunia.com/advisories/30982
- http://secunia.com/advisories/31551
- http://secunia.com/advisories/31614
- http://secunia.com/advisories/32023
- http://secunia.com/advisories/32759
- http://www.debian.org/security/2008/dsa-1630
Get alerted when CVE-2008-2931 or the next vulnerability affects your stack