What’s Vulnerable › Vulnerabilities
CVE-2008-3142
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-08-01 · updated 2026-06-16
- Weakness: CWE-120
Description
Multiple buffer overflows in Python 2.5.2 and earlier on 32bit platforms allow context-dependent attackers to cause a denial of service (crash) or have unspecified other impact via a long string that leads to incorrect memory allocation during Unicode string processing, related to the unicode_resize function and the PyMem_RESIZE macro.
Affected products
- Canonical Ubuntu Linux: 6.06, 7.04, 7.10, 8.04
- Debian Linux: 4.0
- Python: before 2.4.6; from 2.5.0 before 2.5.3 — fixed in 2.4.6, 2.5.3
How to fix
Upgrade to a fixed version: Python 2.4.6, 2.5.3. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=232137
- http://bugs.python.org/file10825/issue2620-gps02-patch.txt
- http://bugs.python.org/issue2620
- http://lists.apple.com/archives/security-announce/2009/Feb/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00006.html
- http://secunia.com/advisories/31305
- http://secunia.com/advisories/31332
- http://secunia.com/advisories/31358
- http://secunia.com/advisories/31365
- http://secunia.com/advisories/31473
- http://secunia.com/advisories/31518
- http://secunia.com/advisories/31687
Get alerted when CVE-2008-3142 or the next vulnerability affects your stack