What’s Vulnerable › Vulnerabilities
CVE-2008-3143
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-08-01 · updated 2026-06-16
- Weakness: CWE-190
Description
Multiple integer overflows in Python before 2.5.2 might allow context-dependent attackers to have an unknown impact via vectors related to (1) Include/pymem.h; (2) _csv.c, (3) _struct.c, (4) arraymodule.c, (5) audioop.c, (6) binascii.c, (7) cPickle.c, (8) cStringIO.c, (9) cjkcodecs/multibytecodec.c, (10) datetimemodule.c, (11) md5.c, (12) rgbimgmodule.c, and (13) stropmodule.c in Modules/; (14) bufferobject.c, (15) listobject.c, and (16) obmalloc.c in Objects/; (17) Parser/node.c; and (18) asdl.c, (19) ast.c, (20) bltinmodule.c, and (21) compile.c in Python/, as addressed by "checks for integer overflows, contributed by Google."
Affected products
- Python: before 2.5.12 — fixed in 2.5.12
How to fix
Upgrade to a fixed version: Python 2.5.12. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=232137
- http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00006.html
- http://secunia.com/advisories/31332
- http://secunia.com/advisories/31365
- http://secunia.com/advisories/31473
- http://secunia.com/advisories/31518
- http://secunia.com/advisories/31687
- http://secunia.com/advisories/32793
- http://secunia.com/advisories/37471
- http://security.gentoo.org/glsa/glsa-200807-16.xml
- http://svn.python.org/view?rev=60793&view=rev
- http://wiki.rpath.com/Advisories:rPSA-2008-0243
Get alerted when CVE-2008-3143 or the next vulnerability affects your stack