What’s Vulnerable › Vulnerabilities
CVE-2008-3218
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-07-18 · updated 2026-06-16
- Weakness: CWE-79
Description
Multiple cross-site scripting (XSS) vulnerabilities in Drupal 6.x before 6.3 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) free tagging taxonomy terms, which are not properly handled on node preview pages, and (2) unspecified OpenID values.
Affected products
- Drupal: from 6.0 before 6.3 — fixed in 6.3
- Fedoraproject Fedora: 8, 9
How to fix
Upgrade to a fixed version: Drupal 6.3. Check the vendor advisory for mitigations.
References
- http://drupal.org/node/280571
- http://secunia.com/advisories/31079
- http://www.openwall.com/lists/oss-security/2008/07/10/3
- http://www.securityfocus.com/bid/30168
- https://bugzilla.redhat.com/show_bug.cgi?id=454849
- https://exchange.xforce.ibmcloud.com/vulnerabilities/43704
- https://www.redhat.com/archives/fedora-package-announce/2008-August/msg00016.html
- https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00527.html
- https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00551.html
- http://drupal.org/node/280571
- http://secunia.com/advisories/31079
- http://www.openwall.com/lists/oss-security/2008/07/10/3
Get alerted when CVE-2008-3218 or the next vulnerability affects your stack