What’s Vulnerable › Vulnerabilities
CVE-2008-3325
- Severity: medium (CVSS 6.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-07-25 · updated 2026-06-16
- Weakness: CWE-352
Description
Cross-site request forgery (CSRF) vulnerability in Moodle 1.6.x before 1.6.7 and 1.7.x before 1.7.5 allows remote attackers to modify profile settings and gain privileges as other users via a link or IMG tag to the user edit profile page.
Affected products
- Debian Linux: 4.0
- Moodle: from 1.6 before 1.6.7; from 1.7 before 1.7.5 — fixed in 1.6.7, 1.7.5
How to fix
Upgrade to a fixed version: Moodle 1.6.7, 1.7.5. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00001.html
- http://moodle.org/mod/forum/discuss.php?d=101405
- http://secunia.com/advisories/31196
- http://secunia.com/advisories/31339
- http://www.debian.org/security/2008/dsa-1691
- http://www.procheckup.com/Vulnerability_PR08-16.php
- http://www.securityfocus.com/archive/1/494658/100/0/threaded
- https://exchange.xforce.ibmcloud.com/vulnerabilities/43964
- http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00001.html
- http://moodle.org/mod/forum/discuss.php?d=101405
- http://secunia.com/advisories/31196
- http://secunia.com/advisories/31339
Get alerted when CVE-2008-3325 or the next vulnerability affects your stack