What’s Vulnerable › Vulnerabilities
CVE-2008-3533
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-08-18 · updated 2026-06-16
- Weakness: CWE-134
Description
Format string vulnerability in the window_error function in yelp-window.c in yelp in Gnome after 2.19.90 and before 2.24 allows remote attackers to execute arbitrary code via format string specifiers in an invalid URI on the command line, as demonstrated by use of yelp within (1) man or (2) ghelp URI handlers in Firefox, Evolution, and unspecified other programs.
Affected products
- Gnome: 2.20, 2.22
- GNOME Yelp: before 2.24 — fixed in 2.24
How to fix
Upgrade to a fixed version: GNOME Yelp 2.24. Check the vendor advisory for mitigations.
References
- http://bugzilla.gnome.org/attachment.cgi?id=115890
- http://bugzilla.gnome.org/show_bug.cgi?id=546364
- http://lists.opensuse.org/opensuse-security-announce/2008-11/msg00000.html
- http://secunia.com/advisories/31465
- http://secunia.com/advisories/31620
- http://secunia.com/advisories/31834
- http://secunia.com/advisories/32629
- http://www.mandriva.com/security/advisories?name=MDVSA-2008:175
- http://www.securityfocus.com/bid/30690
- http://www.ubuntu.com/usn/usn-638-1
- http://www.vupen.com/english/advisories/2008/2393
- https://bugs.launchpad.net/ubuntu/+source/yelp/+bug/254860
Get alerted when CVE-2008-3533 or the next vulnerability affects your stack