What’s Vulnerable › Vulnerabilities
CVE-2008-3909
- Severity: medium (CVSS 5.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-09-04 · updated 2026-06-16
- Weakness: CWE-352
Description
The administration application in Django 0.91, 0.95, and 0.96 stores unauthenticated HTTP POST requests and processes them after successful authentication occurs, which allows remote attackers to conduct cross-site request forgery (CSRF) attacks and delete or modify data via unspecified requests.
Affected products
- Django: from 0.91 before 0.91.3; from 0.95 before 0.95.4; from 0.96 before 0.96.3 — fixed in 0.91.3, 0.95.4, 0.96.3
How to fix
Upgrade to a fixed version: Django 0.91.3, 0.95.4, 0.96.3. Check the vendor advisory for mitigations.
References
- http://osvdb.org/47906
- http://secunia.com/advisories/31837
- http://secunia.com/advisories/31961
- http://www.debian.org/security/2008/dsa-1640
- http://www.djangoproject.com/weblog/2008/sep/02/security/
- http://www.openwall.com/lists/oss-security/2008/09/03/4
- http://www.vupen.com/english/advisories/2008/2533
- https://bugzilla.redhat.com/show_bug.cgi?id=460966
- https://www.redhat.com/archives/fedora-package-announce/2008-September/msg00091.html
- https://www.redhat.com/archives/fedora-package-announce/2008-September/msg00131.html
- http://osvdb.org/47906
- http://secunia.com/advisories/31837
Get alerted when CVE-2008-3909 or the next vulnerability affects your stack