What’s Vulnerable › Vulnerabilities

CVE-2008-4058

Description

The XPConnect component in Mozilla Firefox before 2.0.0.17 and 3.x before 3.0.2, Thunderbird before 2.0.0.17, and SeaMonkey before 1.1.12 allows remote attackers to "pollute XPCNativeWrappers" and execute arbitrary code with chrome privileges via vectors related to (1) chrome XBL and (2) chrome JS.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 2.0.0.17, 3.0.2; Mozilla Seamonkey 1.1.12; Mozilla Thunderbird 2.0.0.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-4058 or the next vulnerability affects your stack