What’s Vulnerable › Vulnerabilities
CVE-2008-4077
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-09-15 · updated 2026-06-16
- Weakness: CWE-400
Description
The CGI scripts in (1) LedgerSMB (LSMB) before 1.2.15 and (2) SQL-Ledger 2.8.17 and earlier allow remote attackers to cause a denial of service (resource exhaustion) via an HTTP POST request with a large Content-Length.
Affected products
- ledgersmb/ledgersmb: before 1.2.15 — fixed in 1.2.15
- Sql-Ledger: through 2.8.17
How to fix
Upgrade to a fixed version: ledgersmb/ledgersmb 1.2.15. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/31843
- http://securityreason.com/securityalert/4250
- http://www.ledgersmb.org/node/70
- http://www.securityfocus.com/archive/1/496181/100/0/threaded
- http://www.securityfocus.com/bid/31109
- https://exchange.xforce.ibmcloud.com/vulnerabilities/45033
- http://secunia.com/advisories/31843
- http://securityreason.com/securityalert/4250
- http://www.ledgersmb.org/node/70
- http://www.securityfocus.com/archive/1/496181/100/0/threaded
- http://www.securityfocus.com/bid/31109
- https://exchange.xforce.ibmcloud.com/vulnerabilities/45033
Get alerted when CVE-2008-4077 or the next vulnerability affects your stack