What’s Vulnerable › Vulnerabilities
CVE-2008-4456
- Severity: low (CVSS 2.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-10-06 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the command-line client in MySQL 5.0.26 through 5.0.45, and other versions including versions later than 5.0.45, when the --html option is enabled, allows attackers to inject arbitrary web script or HTML by placing it in a database cell, which might be accessed by this client when composing an HTML document. NOTE: as of 20081031, the issue has not been fixed in MySQL 5.0.67.
Affected products
- Mysql: 5.0.4, 5.0.30, 5.0.36, 5.0.44
- MySQL Server: 5.0.26, 5.0.27, 5.0.30-sp1, 5.0.32, 5.0.33, 5.0.37 (+5)
References
- http://bugs.mysql.com/bug.php?id=27884
- http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html
- http://seclists.org/bugtraq/2008/Oct/0026.html
- http://secunia.com/advisories/32072
- http://secunia.com/advisories/34907
- http://secunia.com/advisories/36566
- http://secunia.com/advisories/38517
- http://securityreason.com/securityalert/4357
- http://support.apple.com/kb/HT4077
- http://ubuntu.com/usn/usn-897-1
- http://www.debian.org/security/2009/dsa-1783
- http://www.henlich.de/it-security/mysql-command-line-client-html-injection-vulnerability
Get alerted when CVE-2008-4456 or the next vulnerability affects your stack