What’s Vulnerable › Vulnerabilities
CVE-2008-4539
- Severity: high (CVSS 7.2 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-12-29 · updated 2026-06-16
- Weakness: CWE-119
Description
Heap-based buffer overflow in the Cirrus VGA implementation in (1) KVM before kvm-82 and (2) QEMU on Debian GNU/Linux and Ubuntu might allow local users to gain privileges by using the VNC console for a connection, aka the LGD-54XX "bitblt" heap overflow. NOTE: this issue exists because of an incorrect fix for CVE-2007-1320.
Affected products
- Canonical Ubuntu Linux: 8.04, 8.10
- Debian Linux: 4.0, 5.0
- Kvm Qumranet Kvm: through 81
- QEMU: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: QEMU 0.10.0. Check the vendor advisory for mitigations.
References
- http://git.kernel.dk/?p=qemu.git%3Ba=commitdiff%3Bh=65d35a09979e63541afc5bfc595b9f1b1b4ae069
- http://groups.google.com/group/linux.debian.changes.devel/msg/9e0dc008572f2867?dmode=source
- http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00003.html
- http://secunia.com/advisories/25073
- http://secunia.com/advisories/29129
- http://secunia.com/advisories/33350
- http://secunia.com/advisories/34642
- http://secunia.com/advisories/35031
- http://secunia.com/advisories/35062
- http://svn.savannah.gnu.org/viewvc/?view=rev&root=qemu&revision=5587
- http://www.debian.org/security/2009/dsa-1799
- http://www.mail-archive.com/cvs-all%40freebsd.org/msg129730.html
Get alerted when CVE-2008-4539 or the next vulnerability affects your stack