What’s Vulnerable › Vulnerabilities
CVE-2008-4796
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2008-10-30 · updated 2026-06-16
- Weakness: CWE-78
Description
The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.
Affected products
- Debian Linux: 4.0, 5.0
- Nagios Enterprises nagios: before 4.2.2 — fixed in 4.2.2
- Snoopy Project Snoopy: through 1.2.3
- WordPress: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: Nagios Enterprises nagios 4.2.2; WordPress 2.6.3. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN20502807/index.html
- http://jvndb.jvn.jp/ja/contents/2008/JVNDB-2008-000074.html
- http://secunia.com/advisories/32361
- http://sourceforge.net/forum/forum.php?forum_id=879959
- http://www.debian.org/security/2008/dsa-1691
- http://www.debian.org/security/2009/dsa-1871
- http://www.openwall.com/lists/oss-security/2008/11/01/1
- http://www.securityfocus.com/archive/1/496068/100/0/threaded
- http://www.securityfocus.com/bid/31887
- http://www.vupen.com/english/advisories/2008/2901
- https://exchange.xforce.ibmcloud.com/vulnerabilities/46068
- https://security.gentoo.org/glsa/201702-26
Get alerted when CVE-2008-4796 or the next vulnerability affects your stack