What’s Vulnerable › Vulnerabilities

CVE-2008-4864

Description

Multiple integer overflows in imageop.c in the imageop module in Python 1.5.2 through 2.5.1 allow context-dependent attackers to break out of the Python VM and execute arbitrary code via large integer values in certain arguments to the crop function, leading to a buffer overflow, a different vulnerability than CVE-2007-4965 and CVE-2008-1679.

Affected products

How to fix

Upgrade to a fixed version: Python 2.4.6, 2.5.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-4864 or the next vulnerability affects your stack