What’s Vulnerable › Vulnerabilities

CVE-2008-5024

Description

Mozilla Firefox 3.x before 3.0.4, Firefox 2.x before 2.0.0.18, Thunderbird 2.x before 2.0.0.18, and SeaMonkey 1.x before 1.1.13 do not properly escape quote characters used for XML processing, which allows remote attackers to conduct XML injection attacks via the default namespace in an E4X document.

Affected products

How to fix

Upgrade to a fixed version: Mozilla Firefox 2.0.0.18, 3.0.4; Mozilla Seamonkey 1.1.13; Mozilla Thunderbird 2.0.0.18. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-5024 or the next vulnerability affects your stack