What’s Vulnerable › Vulnerabilities

CVE-2008-5363

Description

The ActionScript 2 virtual machine in Adobe Flash Player 10.x before 10.0.12.36 and 9.x before 9.0.151.0, and Adobe AIR before 1.5, does not validate character elements during retrieval from the dictionary data structure, which allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a crafted PDF file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Air 1.5; Adobe Flash Player 24.0.0.186 and earlier. 10.0.12.36, 9.0.151.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2008-5363 or the next vulnerability affects your stack