What’s Vulnerable › Vulnerabilities
CVE-2008-5695
- Severity: high (CVSS 8.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2008-12-19 · updated 2026-06-16
- Weakness: CWE-20
Description
wp-admin/options.php in WordPress MU before 1.3.2, and WordPress 2.3.2 and earlier, does not properly validate requests to update an option, which allows remote authenticated users with manage_options and upload_files capabilities to execute arbitrary code by uploading a PHP script and adding this script's pathname to active_plugins.
Affected products
- WordPress: through 2.3.2
- Wordpress Mu: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Wordpress Mu 1.3.2. Check the vendor advisory for mitigations.
References
- http://mu.wordpress.org/forums/topic.php?id=7534&page&replies=1
- http://secunia.com/advisories/28789
- http://securityreason.com/securityalert/4798
- http://www.buayacorp.com/files/wordpress/wordpress-mu-options-overwrite.html
- http://www.buayacorp.com/files/wordpress/wp-blog-option-overwrite.txt
- http://www.securityfocus.com/bid/27633
- https://www.exploit-db.com/exploits/5066
- http://mu.wordpress.org/forums/topic.php?id=7534&page&replies=1
- http://secunia.com/advisories/28789
- http://securityreason.com/securityalert/4798
- http://www.buayacorp.com/files/wordpress/wordpress-mu-options-overwrite.html
- http://www.buayacorp.com/files/wordpress/wp-blog-option-overwrite.txt
Get alerted when CVE-2008-5695 or the next vulnerability affects your stack