What’s Vulnerable › Vulnerabilities
CVE-2008-6124
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-02-13 · updated 2026-06-16
- Weakness: CWE-89
Description
SQL injection vulnerability in the hotpot_delete_selected_attempts function in report.php in the HotPot module in Moodle 1.6 before 1.6.7, 1.7 before 1.7.5, 1.8 before 1.8.6, and 1.9 before 1.9.2 allows remote attackers to execute arbitrary SQL commands via a crafted selected attempt.
Affected products
- Debian Linux: 4.0
- Moodle: from 1.6 before 1.6.7; from 1.7 before 1.7.5; from 1.8 before 1.8.6; from 1.9 before 1.9.2 — fixed in 1.6.7, 1.7.5, 1.8.6, 1.9.2
How to fix
Upgrade to a fixed version: Moodle 1.6.7, 1.7.5, 1.8.6, 1.9.2. Check the vendor advisory for mitigations.
References
- http://cvs.moodle.org/moodle/mod/hotpot/report.php?r1=1.8.6.1&r2=1.8.6.2
- http://moodle.org/mod/forum/discuss.php?d=101402
- http://www.debian.org/security/2008/dsa-1691
- http://cvs.moodle.org/moodle/mod/hotpot/report.php?r1=1.8.6.1&r2=1.8.6.2
- http://moodle.org/mod/forum/discuss.php?d=101402
- http://www.debian.org/security/2008/dsa-1691
Get alerted when CVE-2008-6124 or the next vulnerability affects your stack