What’s Vulnerable › Vulnerabilities
CVE-2008-6540
- Severity: medium (CVSS 5.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-03-30 · updated 2026-06-16
- Weakness: CWE-264
Description
DotNetNuke before 4.8.2, during installation or upgrade, does not warn the administrator when the default (1) ValidationKey and (2) DecryptionKey values cannot be modified in the web.config file, which allows remote attackers to bypass intended access restrictions by using the default keys.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: through 4.8.1; 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.0.10d, 1.0.10e (+10)
References
- http://osvdb.org/43720
- http://secunia.com/advisories/29488
- http://www.dotnetnuke.com/News/SecurityBulletins/SecurityBulletinno12/tabid/1148/Default.aspx
- http://www.securityfocus.com/archive/1/489957/100/0/threaded
- http://www.securityfocus.com/bid/28391
- https://exchange.xforce.ibmcloud.com/vulnerabilities/41399
- http://osvdb.org/43720
- http://secunia.com/advisories/29488
- http://www.dotnetnuke.com/News/SecurityBulletins/SecurityBulletinno12/tabid/1148/Default.aspx
- http://www.securityfocus.com/archive/1/489957/100/0/threaded
- http://www.securityfocus.com/bid/28391
- https://exchange.xforce.ibmcloud.com/vulnerabilities/41399
Get alerted when CVE-2008-6540 or the next vulnerability affects your stack