What’s Vulnerable › Vulnerabilities
CVE-2008-7272
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-08 · updated 2026-06-16
- Weakness: CWE-312
Description
FireGPG before 0.6 handle user’s passphrase and decrypted cleartext insecurely by writing pre-encrypted cleartext and the user's passphrase to disk which may result in the compromise of secure communication or a users’s private key.
Affected products
- Getfiregpg Firegpg: before 0.6 — fixed in 0.6
How to fix
Upgrade to a fixed version: Getfiregpg Firegpg 0.6. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=514386
- https://security-tracker.debian.org/tracker/CVE-2008-7272
- https://vulners.com/securityvulns/SECURITYVULNS:DOC:20757?utm_source=securityvulns&utm_medium=redirect
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=514386
- https://security-tracker.debian.org/tracker/CVE-2008-7272
- https://vulners.com/securityvulns/SECURITYVULNS:DOC:20757?utm_source=securityvulns&utm_medium=redirect
Get alerted when CVE-2008-7272 or the next vulnerability affects your stack