What’s Vulnerable › Vulnerabilities
CVE-2009-0193
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-03-25 · updated 2026-06-16
- Weakness: CWE-119
Description
Heap-based buffer overflow in Adobe Acrobat Reader 9 before 9.1, 8 before 8.1.4, and 7 before 7.1.1 allows remote attackers to execute arbitrary code via a PDF file with a malformed JBIG2 symbol dictionary segment, a different vulnerability than CVE-2009-1061 and CVE-2009-1062.
Affected products
- Adobe Acrobat Reader: from 7.0 before 7.1.1; from 8.0 before 8.1.4; from 9.0 before 9.1 — fixed in 7.1.1, 8.1.4, 9.1
How to fix
Upgrade to a fixed version: Adobe Acrobat Reader 7.1.1, 8.1.4, 9.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00010.html
- http://secunia.com/advisories/34392
- http://secunia.com/advisories/34490
- http://secunia.com/advisories/34706
- http://secunia.com/advisories/34790
- http://secunia.com/secunia_research/2009-14/
- http://security.gentoo.org/glsa/glsa-200904-17.xml
- http://sunsolve.sun.com/search/document.do?assetkey=1-66-256788-1
- http://www.adobe.com/support/security/bulletins/apsb09-04.html
- http://www.redhat.com/support/errata/RHSA-2009-0376.html
- http://www.securityfocus.com/archive/1/502155/100/0/threaded
Get alerted when CVE-2009-0193 or the next vulnerability affects your stack