What’s Vulnerable › Vulnerabilities
CVE-2009-0490
- Severity: critical (CVSS 9.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-02-10 · updated 2026-06-16
- Weakness: CWE-787
Description
Stack-based buffer overflow in the String_parse::get_nonspace_quoted function in lib-src/allegro/strparse.cpp in Audacity 1.2.6 and other versions before 1.3.6 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a .gro file containing a long string.
Affected products
- Audacityteam Audacity: before 1.3.6 — fixed in 1.3.6
How to fix
Upgrade to a fixed version: Audacityteam Audacity 1.3.6. Check the vendor advisory for mitigations.
References
- http://bugs.gentoo.org/show_bug.cgi?id=253493
- http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00002.html
- http://n2.nabble.com/Audacity-%22String_parse::get_nonspace_quoted%28%29%22-Buffer-Overflow-td2139537.html
- http://osvdb.org/51070
- http://secunia.com/advisories/33356
- http://www.securityfocus.com/bid/33090
- http://www.vupen.com/english/advisories/2009/0008
- https://www.exploit-db.com/exploits/7634
- http://bugs.gentoo.org/show_bug.cgi?id=253493
- http://lists.opensuse.org/opensuse-security-announce/2009-02/msg00002.html
- http://n2.nabble.com/Audacity-%22String_parse::get_nonspace_quoted%28%29%22-Buffer-Overflow-td2139537.html
- http://osvdb.org/51070
Get alerted when CVE-2009-0490 or the next vulnerability affects your stack