What’s Vulnerable › Vulnerabilities
CVE-2009-0586
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-03-14 · updated 2026-06-16
- Weakness: CWE-190
Description
Integer overflow in the gst_vorbis_tag_add_coverart function (gst-libs/gst/tag/gstvorbistag.c) in vorbistag in gst-plugins-base (aka gstreamer-plugins-base) before 0.10.23 in GStreamer allows context-dependent attackers to execute arbitrary code via a crafted COVERART tag that is converted from a base64 representation, which triggers a heap-based buffer overflow.
Affected products
- Canonical Ubuntu Linux: 8.10
- GStreamer: before 0.10.23 — fixed in 0.10.23
How to fix
Upgrade to a fixed version: GStreamer 0.10.23. Check the vendor advisory for mitigations.
References
- http://cgit.freedesktop.org/gstreamer/gst-plugins-base/commit/?id=566583e87147f774e7fc4c78b5f7e61d427e40a9
- http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00010.html
- http://ocert.org/patches/2008-015/gst-plugins-base-CVE-2009-0586.diff
- http://openwall.com/lists/oss-security/2009/03/12/2
- http://secunia.com/advisories/34335
- http://secunia.com/advisories/34350
- http://secunia.com/advisories/35777
- http://security.gentoo.org/glsa/glsa-200907-11.xml
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:085
- http://www.ocert.org/advisories/ocert-2008-015.html
- http://www.securityfocus.com/archive/1/501712/100/0/threaded
- http://www.securityfocus.com/bid/34100
Get alerted when CVE-2009-0586 or the next vulnerability affects your stack