What’s Vulnerable › Vulnerabilities
CVE-2009-0590
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-03-27 · updated 2026-06-16
- Weakness: CWE-119
Description
The ASN1_STRING_print_ex function in OpenSSL before 0.9.8k allows remote attackers to cause a denial of service (invalid memory access and application crash) via vectors that trigger printing of a (1) BMPString or (2) UniversalString with an invalid encoded length.
Affected products
- Debian Linux: 4.0, 5.0
- OpenSSL: before 0.9.8k — fixed in 0.9.8k
How to fix
Upgrade to a fixed version: OpenSSL 0.9.8k. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2009/Sep/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2009-05/msg00000.html
- http://lists.opensuse.org/opensuse-security-announce/2011-07/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2011-07/msg00014.html
- http://lists.vmware.com/pipermail/security-announce/2010/000082.html
- http://marc.info/?l=bugtraq&m=124464882609472&w=2
- http://marc.info/?l=bugtraq&m=125017764422557&w=2
- http://marc.info/?l=bugtraq&m=127678688104458&w=2
- http://secunia.com/advisories/34411
- http://secunia.com/advisories/34460
- http://secunia.com/advisories/34509
Get alerted when CVE-2009-0590 or the next vulnerability affects your stack