What’s Vulnerable › Vulnerabilities
CVE-2009-0927: Adobe Reader and Adobe Acrobat Stack-Based Buffer Overflow Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 96.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-03-19 · updated 2026-06-16
- Weakness: CWE-20
Description
Stack-based buffer overflow in Adobe Reader and Adobe Acrobat 9 before 9.1, 8 before 8.1.3 , and 7 before 7.1.1 allows remote attackers to execute arbitrary code via a crafted argument to the getIcon method of a Collab object, a different vulnerability than CVE-2009-0658.
Affected products
- Adobe Acrobat Reader: from 7.0 before 7.1.1; from 8.0 before 8.1.3; from 9.0 before 9.1 — fixed in 7.1.1, 8.1.3, 9.1
How to fix
Upgrade to a fixed version: Adobe Acrobat Reader 7.1.1, 8.1.3, 9.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00010.html
- http://secunia.com/advisories/34490
- http://secunia.com/advisories/34706
- http://secunia.com/advisories/34790
- http://security.gentoo.org/glsa/glsa-200904-17.xml
- http://sunsolve.sun.com/search/document.do?assetkey=1-66-256788-1
- http://www.adobe.com/support/security/bulletins/apsb09-04.html
- http://www.exploit-db.com/exploits/9579
- http://www.securityfocus.com/archive/1/502116/100/0/threaded
- http://www.securityfocus.com/bid/34169
- http://www.securitytracker.com/id?1021861
Get alerted when CVE-2009-0927 or the next vulnerability affects your stack