What’s Vulnerable › Vulnerabilities
CVE-2009-10003: capnsquarepants wordcraft tag.php cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-29 · updated 2026-06-16
- Weakness: CWE-79
Description
A vulnerability was found in capnsquarepants wordcraft up to 0.6. It has been classified as problematic. Affected is an unknown function of the file tag.php. The manipulation of the argument tag leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 0.7 is able to address this issue. The patch is identified as be23028633e8105de92f387036871c03f34d3124. It is recommended to upgrade the affected component. VDB-219714 is the identifier assigned to this vulnerability.
Affected products
- capnsquarepants wordcraft: before 0.7 — fixed in 0.7
How to fix
Upgrade to a fixed version: capnsquarepants wordcraft 0.7. Check the vendor advisory for mitigations.
References
- https://github.com/capnsquarepants/wordcraft/commit/be23028633e8105de92f387036871c03f34d3124
- https://github.com/capnsquarepants/wordcraft/releases/tag/wordcraft-0.7
- https://vuldb.com/?ctiid.219714
- https://vuldb.com/?id.219714
- https://github.com/capnsquarepants/wordcraft/commit/be23028633e8105de92f387036871c03f34d3124
- https://github.com/capnsquarepants/wordcraft/releases/tag/wordcraft-0.7
- https://vuldb.com/?ctiid.219714
- https://vuldb.com/?id.219714
Get alerted when CVE-2009-10003 or the next vulnerability affects your stack