What’s Vulnerable › Vulnerabilities
CVE-2009-1048
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-08-14 · updated 2026-06-16
- Weakness: CWE-290
Description
The web interface on the snom VoIP phones snom 300, snom 320, snom 360, snom 370, and snom 820 with firmware 6.5 before 6.5.20, 7.1 before 7.1.39, and 7.3 before 7.3.14 allows remote attackers to bypass authentication, and reconfigure the phone or make arbitrary use of the phone, via a (1) http or (2) https request with 127.0.0.1 in the Host header.
Affected products
- Snom 300 Firmware: from 6.5 before 6.5.20; from 7.1 before 7.1.39; from 7.3 before 7.3.14 — fixed in 6.5.20, 7.1.39, 7.3.14
- Snom 320 Firmware: from 6.5 before 6.5.20; from 7.1 before 7.1.39; from 7.3 before 7.3.14 — fixed in 6.5.20, 7.1.39, 7.3.14
- Snom 360 Firmware: from 6.5 before 6.5.20; from 7.1 before 7.1.39; from 7.3 before 7.3.14 — fixed in 6.5.20, 7.1.39, 7.3.14
- Snom 370 Firmware: from 6.5 before 6.5.20; from 7.1 before 7.1.39; from 7.3 before 7.3.14 — fixed in 6.5.20, 7.1.39, 7.3.14
- Snom 820 Firmware: from 6.5 before 6.5.20; from 7.1 before 7.1.39; from 7.3 before 7.3.14 — fixed in 6.5.20, 7.1.39, 7.3.14
How to fix
Upgrade to a fixed version: Snom 300 Firmware 6.5.20, 7.1.39, 7.3.14; Snom 320 Firmware 6.5.20, 7.1.39, 7.3.14; Snom 360 Firmware 6.5.20, 7.1.39, 7.3.14; Snom 370 Firmware 6.5.20, 7.1.39, 7.3.14; Snom 820 Firmware 6.5.20, 7.1.39, 7.3.14. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/36293
- http://www.csnc.ch/misc/files/advisories/cve-2009-1048.txt
- http://www.securityfocus.com/archive/1/505723/100/0/threaded
- https://exchange.xforce.ibmcloud.com/vulnerabilities/52424
- http://secunia.com/advisories/36293
- http://www.csnc.ch/misc/files/advisories/cve-2009-1048.txt
- http://www.securityfocus.com/archive/1/505723/100/0/threaded
- https://exchange.xforce.ibmcloud.com/vulnerabilities/52424
Get alerted when CVE-2009-1048 or the next vulnerability affects your stack