What’s Vulnerable › Vulnerabilities
CVE-2009-1073
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-03-31 · updated 2026-06-16
- Weakness: CWE-732
Description
nss-ldapd before 0.6.8 uses world-readable permissions for the /etc/nss-ldapd.conf file, which allows local users to obtain a cleartext password for the LDAP server by reading the bindpw field.
Affected products
- Debian Linux: 5.0
- Debian Nss-Ldap: before 0.6.8 — fixed in 0.6.8
How to fix
Upgrade to a fixed version: Debian Nss-Ldap 0.6.8. Check the vendor advisory for mitigations.
References
- http://arthurenhella.demon.nl/viewvc/nss-ldapd/nss-ldapd/debian/libnss-ldapd.postinst?r1=795&r2=813
- http://arthurenhella.demon.nl/viewvc/nss-ldapd/nss-ldapd/man/nss-ldapd.conf.5.xml?r1=805&r2=806
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=520476
- http://ch.tudelft.nl/~arthur/nss-ldapd/news.html#20090322
- http://launchpad.net/bugs/cve/2009-1073
- http://secunia.com/advisories/34523
- http://www.debian.org/security/2009/dsa-1758
- http://www.openwall.com/lists/oss-security/2009/03/23/3
- http://www.openwall.com/lists/oss-security/2009/03/24/2
- http://www.openwall.com/lists/oss-security/2009/03/25/3
- http://www.openwall.com/lists/oss-security/2009/03/25/4
- http://www.securityfocus.com/bid/34211
Get alerted when CVE-2009-1073 or the next vulnerability affects your stack