What’s Vulnerable › Vulnerabilities
CVE-2009-1151: phpMyAdmin Remote Code Execution Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-25
- EPSS: 96.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-03-26 · updated 2026-06-16
- Weakness: CWE-94
Description
Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allows remote attackers to inject arbitrary PHP code into a configuration file via the save action.
Affected products
- Debian Linux: 4.0, 5.0
- phpMyAdmin: from 2.11.0 before 2.11.9.5; from 3.0.0 before 3.1.3.1 — fixed in 2.11.9.5, 3.1.3.1
How to fix
Upgrade to a fixed version: phpMyAdmin 2.11.9.5, 3.1.3.1. Check the vendor advisory for mitigations.
References
- http://labs.neohapsis.com/2009/04/06/about-cve-2009-1151/
- http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00003.html
- http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/MAINT_2_11_9/phpMyAdmin/scripts/setup.php?r1=11514&r2=12301&pathrev=12301
- http://secunia.com/advisories/34430
- http://secunia.com/advisories/34642
- http://secunia.com/advisories/35585
- http://secunia.com/advisories/35635
- http://security.gentoo.org/glsa/glsa-200906-03.xml
- http://www.debian.org/security/2009/dsa-1824
- http://www.gnucitizen.org/blog/cve-2009-1151-phpmyadmin-remote-code-execution-proof-of-concept/
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:115
- http://www.phpmyadmin.net/home_page/security/PMASA-2009-3.php
Get alerted when CVE-2009-1151 or the next vulnerability affects your stack