What’s Vulnerable › Vulnerabilities
CVE-2009-1184
- Severity: medium (CVSS 4.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-05-05 · updated 2026-06-16
- Weakness: CWE-16
Description
The selinux_ip_postroute_iptables_compat function in security/selinux/hooks.c in the SELinux subsystem in the Linux kernel before 2.6.27.22, and 2.6.28.x before 2.6.28.10, when compat_net is enabled, omits calls to avc_has_perm for the (1) node and (2) port, which allows local users to bypass intended restrictions on network traffic. NOTE: this was incorrectly reported as an issue fixed in 2.6.27.21.
Affected products
- Linux kernel: 2.2.27, 2.4.36, 2.4.36.1, 2.4.36.2, 2.4.36.3, 2.4.36.4 (+316)
References
- http://git.kernel.org/?p=linux/kernel/git/stable/linux-2.6.27.y.git%3Ba=commit%3Bh=910c9e41186762de3717baaf392ab5ff0c454496
- http://lwn.net/Articles/331434/
- http://lwn.net/Articles/331435/
- http://patchwork.ozlabs.org/patch/25238/
- http://secunia.com/advisories/35121
- http://secunia.com/advisories/35656
- http://www.debian.org/security/2009/dsa-1800
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:118
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:119
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:135
- http://www.openwall.com/lists/oss-security/2009/05/04/1
- http://www.ubuntu.com/usn/usn-793-1
Get alerted when CVE-2009-1184 or the next vulnerability affects your stack