What’s Vulnerable › Vulnerabilities
CVE-2009-1198
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-10-30 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in Apache jUDDI before 2.0 allows remote attackers to inject arbitrary web script or HTML via the dsname parameter to happyjuddi.jsp.
Affected products
- Apache Software Foundation Apache jUDDI: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache jUDDI 2.0. Check the vendor advisory for mitigations.
References
- http://issues.apache.org/jira/browse/JUDDI-221
- http://marc.info/?l=juddi-dev&m=125000625404010&w=2
- http://www.securityfocus.com/bid/101623
- http://issues.apache.org/jira/browse/JUDDI-221
- http://marc.info/?l=juddi-dev&m=125000625404010&w=2
- http://www.securityfocus.com/bid/101623
Get alerted when CVE-2009-1198 or the next vulnerability affects your stack