What’s Vulnerable › Vulnerabilities
CVE-2009-1415
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-04-30 · updated 2026-06-16
- Weakness: CWE-824
Description
lib/pk-libgcrypt.c in libgnutls in GnuTLS before 2.6.6 does not properly handle invalid DSA signatures, which allows remote attackers to cause a denial of service (application crash) and possibly have unspecified other impact via a malformed DSA key that triggers a (1) free of an uninitialized pointer or (2) double free.
Affected products
- [UNKNOWN] gnutls: before 2.6.6 — fixed in 2.6.6
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 2.6.6. Check the vendor advisory for mitigations.
References
- http://article.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/3515
- http://permalink.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/3502
- http://secunia.com/advisories/34842
- http://secunia.com/advisories/35211
- http://security.gentoo.org/glsa/glsa-200905-04.xml
- http://thread.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/3488
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:116
- http://www.securityfocus.com/bid/34783
- http://www.securitytracker.com/id?1022157
- http://www.vupen.com/english/advisories/2009/1218
- https://exchange.xforce.ibmcloud.com/vulnerabilities/50257
- https://exchange.xforce.ibmcloud.com/vulnerabilities/50260
Get alerted when CVE-2009-1415 or the next vulnerability affects your stack