What’s Vulnerable › Vulnerabilities
CVE-2009-1721
- Severity: medium (CVSS 6.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-07-31 · updated 2026-06-16
- Weakness: CWE-824
Description
The decompression implementation in the Imf::hufUncompress function in OpenEXR 1.2.2 and 1.6.1 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger a free of an uninitialized pointer.
Affected products
- macOS: before 10.5.8 — fixed in 10.5.8
- Canonical Ubuntu Linux: 8.04, 8.10, 9.04
- Debian Linux: 4.0, 5.0
- Fedoraproject Fedora: 10, 11
- AcademySoftwareFoundation openexr: 1.2.2, 1.6.1
- Opensuse: 10.0, 10.3, 11.0
How to fix
Upgrade to a fixed version: macOS 10.5.8. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2009/Aug/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2009-09/msg00000.html
- http://release.debian.org/proposed-updates/stable_diffs/openexr_1.6.1-3%2Blenny3.debdiff
- http://secunia.com/advisories/36030
- http://secunia.com/advisories/36032
- http://secunia.com/advisories/36096
- http://secunia.com/advisories/36123
- http://secunia.com/advisories/36753
- http://security.debian.org/pool/updates/main/o/openexr/openexr_1.2.2-4.3+etch2.diff.gz
- http://security.debian.org/pool/updates/main/o/openexr/openexr_1.6.1-3+lenny3.diff.gz
- http://support.apple.com/kb/HT3757
- http://www.debian.org/security/2009/dsa-1842
Get alerted when CVE-2009-1721 or the next vulnerability affects your stack