What’s Vulnerable › Vulnerabilities
CVE-2009-1879
- Severity: low (CVSS 2.6 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-08-21 · updated 2026-06-16
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in index.template.html in the express-install templates in the SDK in Adobe Flex before 3.4, when the installed Flash version is older than a specified requiredMajorVersion value, allows remote attackers to inject arbitrary web script or HTML via the query string.
Affected products
- Adobe Flex Sdk: before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: Adobe Flex Sdk 3.4. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/36374
- http://securitytracker.com/id?1022748
- http://www.adobe.com/support/security/bulletins/apsb09-13.html
- http://www.gdssecurity.com/l/b/2009/08/20/adobe-flex-3-3-sdk-dom-based-xss/
- http://www.securityfocus.com/archive/1/505948/100/0/threaded
- https://exchange.xforce.ibmcloud.com/vulnerabilities/52608
- http://secunia.com/advisories/36374
- http://securitytracker.com/id?1022748
- http://www.adobe.com/support/security/bulletins/apsb09-13.html
- http://www.gdssecurity.com/l/b/2009/08/20/adobe-flex-3-3-sdk-dom-based-xss/
- http://www.securityfocus.com/archive/1/505948/100/0/threaded
- https://exchange.xforce.ibmcloud.com/vulnerabilities/52608
Get alerted when CVE-2009-1879 or the next vulnerability affects your stack