What’s Vulnerable › Vulnerabilities
CVE-2009-1888
- Severity: medium (CVSS 5.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-06-25 · updated 2026-06-16
- Weakness: CWE-264
Description
The acl_group_override function in smbd/posix_acls.c in smbd in Samba 3.0.x before 3.0.35, 3.1.x and 3.2.x before 3.2.13, and 3.3.x before 3.3.6, when dos filemode is enabled, allows remote attackers to modify access control lists for files via vectors related to read access to uninitialized memory.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04
- Debian Linux: 4.0, 5.0
- Samba: from 3.0.31 through 3.0.35; from 3.2.0 before 3.2.13; from 3.3.0 before 3.3.6 — fixed in 3.2.13, 3.3.6
How to fix
Upgrade to a fixed version: Samba 3.2.13, 3.3.6. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/35539
- http://secunia.com/advisories/35573
- http://secunia.com/advisories/35606
- http://secunia.com/advisories/36918
- http://wiki.rpath.com/Advisories:rPSA-2009-0145
- http://www.debian.org/security/2009/dsa-1823
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:196
- http://www.samba.org/samba/ftp/patches/security/samba-3.0.34-CVE-2009-1888.patch
- http://www.samba.org/samba/ftp/patches/security/samba-3.2.12-CVE-2009-1888.patch
- http://www.samba.org/samba/ftp/patches/security/samba-3.3.5-CVE-2009-1888.patch
- http://www.samba.org/samba/security/CVE-2009-1888.html
- http://www.securityfocus.com/archive/1/507856/100/0/threaded
Get alerted when CVE-2009-1888 or the next vulnerability affects your stack