What’s Vulnerable › Vulnerabilities
CVE-2009-1903
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-06-03 · updated 2026-06-16
Description
The PDF XSS protection feature in ModSecurity before 2.5.8 allows remote attackers to cause a denial of service (Apache httpd crash) via a request for a PDF file that does not use the GET method.
Affected products
- Fedoraproject Fedora: 9, 10
- Trustwave Modsecurity: before 2.5.8 — fixed in 2.5.8
How to fix
Upgrade to a fixed version: Trustwave Modsecurity 2.5.8. Check the vendor advisory for mitigations.
References
- http://secunia.com/advisories/34256
- http://secunia.com/advisories/34311
- http://secunia.com/advisories/35687
- http://security.gentoo.org/glsa/glsa-200907-02.xml
- http://sourceforge.net/project/shownotes.php?release_id=667538
- http://www.osvdb.org/52552
- http://www.securityfocus.com/bid/34096
- http://www.vupen.com/english/advisories/2009/0703
- https://exchange.xforce.ibmcloud.com/vulnerabilities/49211
- https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00487.html
- https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00529.html
- http://secunia.com/advisories/34256
Get alerted when CVE-2009-1903 or the next vulnerability affects your stack