What’s Vulnerable › Vulnerabilities

CVE-2009-1955

Description

The expat XML parser in the apr_xml_* interface in xml/apr_xml.c in Apache APR-util before 1.3.7, as used in the mod_dav and mod_dav_svn modules in the Apache HTTP Server, allows remote attackers to cause a denial of service (memory consumption) via a crafted XML document containing a large number of nested entity references, as demonstrated by a PROPFIND request, a similar issue to CVE-2003-1564.

Affected products

How to fix

Upgrade to a fixed version: Apache Apr-Util 1.3.7; Apache HTTP Server 2.2.12; macOS 10.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2009-1955 or the next vulnerability affects your stack