What’s Vulnerable › Vulnerabilities
CVE-2009-1956
- Severity: medium (CVSS 6.4 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-06-08 · updated 2026-06-16
- Weakness: CWE-189
Description
Off-by-one error in the apr_brigade_vprintf function in Apache APR-util before 1.3.5 on big-endian platforms allows remote attackers to obtain sensitive information or cause a denial of service (application crash) via crafted input.
Affected products
- Apache Apr-Util: through 1.3.4
- Apache HTTP Server: from 2.2.0 before 2.2.12 — fixed in 2.2.12
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.2.12. Check the vendor advisory for mitigations.
References
- http://lists.apple.com/archives/security-announce/2009/Nov/msg00000.html
- http://marc.info/?l=bugtraq&m=129190899612998&w=2
- http://secunia.com/advisories/34724
- http://secunia.com/advisories/35284
- http://secunia.com/advisories/35395
- http://secunia.com/advisories/35487
- http://secunia.com/advisories/35565
- http://secunia.com/advisories/35710
- http://secunia.com/advisories/35797
- http://secunia.com/advisories/35843
- http://secunia.com/advisories/37221
- http://security.gentoo.org/glsa/glsa-200907-03.xml
Get alerted when CVE-2009-1956 or the next vulnerability affects your stack