What’s Vulnerable › Vulnerabilities

CVE-2009-1961

Description

The inode double locking code in fs/ocfs2/file.c in the Linux kernel 2.6.30 before 2.6.30-rc3, 2.6.27 before 2.6.27.24, 2.6.29 before 2.6.29.4, and possibly other versions down to 2.6.19 allows local users to cause a denial of service (prevention of file creation and removal) via a series of splice system calls that trigger a deadlock between the generic_file_splice_write, splice_from_pipe, and ocfs2_file_splice_write functions.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 2.6.27.24, 2.6.29.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2009-1961 or the next vulnerability affects your stack