What’s Vulnerable › Vulnerabilities
CVE-2009-20011: ContentKeeper Web Appliance < 125.10 RCE via mimencode
- Severity: critical (CVSS 10.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-30 · updated 2026-10-01
- Weakness: CWE-78
Description
ContentKeeper Web Appliance (now maintained by Impero Software) versions prior to 125.10 are vulnerable to remote command execution due to insecure handling of file uploads via the mimencode CGI utility. The vulnerability allows unauthenticated attackers to upload and execute arbitrary scripts as the Apache user. Additionally, the exploit can optionally escalate privileges by abusing insecure PATH usage in the benetool binary, resulting in root-level access if successful.
Affected products
- ContentKeeper Technologies ContentKeeper Web Appliance: before 125.10 — fixed in 125.10
How to fix
Upgrade to a fixed version: ContentKeeper Technologies ContentKeeper Web Appliance 125.10. Check the vendor advisory for mitigations.
References
- http://www.aushack.com/200904-contentkeeper.txt
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/unix/http/contentkeeperweb_mimencode.rb
- https://web.archive.org/web/20081220084819/http://www.contentkeeper.com/
- https://www.ativion.com/contentkeeper/
- https://www.vulncheck.com/advisories/contentkeeper-web-appliance-rce-via-mimencode
Get alerted when CVE-2009-20011 or the next vulnerability affects your stack