What’s Vulnerable › Vulnerabilities
CVE-2009-2051
- Severity: high (CVSS 7.8 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2009-08-27 · updated 2026-06-16
Description
Cisco IOS 12.2 through 12.4 and 15.0 through 15.1, Cisco IOS XE 2.5.x and 2.6.x before 2.6.1, and Cisco Unified Communications Manager (aka CUCM, formerly CallManager) 4.x, 5.x before 5.1(3g), 6.x before 6.1(4), and 7.x before 7.1(2) allow remote attackers to cause a denial of service (device reload or voice-services outage) via a malformed SIP INVITE message that triggers an improper call to the sipSafeStrlen function, aka Bug IDs CSCsz40392 and CSCsz43987.
Affected products
- Cisco IOS: from 12.2 through 12.4; from 15.0 through 15.1
- Cisco IOS XE: from 2.5.0 through 2.6.1
- Cisco Unified Communications Manager: from 5.0 before 5.1\(3g\); from 6.1\(1\) before 6.1\(4\); from 7.1 before 7.1\(2\) — fixed in 5.1\(3g\), 6.1\(4\), 7.1\(2\)
How to fix
Upgrade to a fixed version: Cisco Unified Communications Manager 5.1\(3g\), 6.1\(4\), 7.1\(2\). Check the vendor advisory for mitigations.
References
- http://osvdb.org/57453
- http://secunia.com/advisories/36498
- http://secunia.com/advisories/36499
- http://www.cisco.com/en/US/products/products_security_advisory09186a0080af2d11.shtml
- http://www.cisco.com/en/US/products/products_security_advisory09186a0080b4a30f.shtml
- http://www.securityfocus.com/bid/36152
- http://www.securitytracker.com/id?1022775
- http://osvdb.org/57453
- http://secunia.com/advisories/36498
- http://secunia.com/advisories/36499
- http://www.cisco.com/en/US/products/products_security_advisory09186a0080af2d11.shtml
- http://www.cisco.com/en/US/products/products_security_advisory09186a0080b4a30f.shtml
Get alerted when CVE-2009-2051 or the next vulnerability affects your stack