What’s Vulnerable › Vulnerabilities
CVE-2009-2335
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 85.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-07-10 · updated 2026-06-16
- Weakness: CWE-16
Description
WordPress and WordPress MU before 2.8.1 exhibit different behavior for a failed login attempt depending on whether the user account exists, which allows remote attackers to enumerate valid usernames. NOTE: the vendor reportedly disputes the significance of this issue, indicating that the behavior exists for "user convenience."
Affected products
- WordPress: before 2.8.1 — fixed in 2.8.1
- Wordpress Mu: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: WordPress 2.8.1; Wordpress Mu 2.8.1. Check the vendor advisory for mitigations.
References
- http://corelabs.coresecurity.com/index.php?action=view&type=advisory&name=WordPress_Privileges_Unchecked
- http://securitytracker.com/id?1022528
- http://www.exploit-db.com/exploits/9110
- http://www.osvdb.org/55713
- http://www.securityfocus.com/archive/1/504795/100/0/threaded
- http://www.securityfocus.com/bid/35581
- http://www.vupen.com/english/advisories/2009/1833
- https://www.redhat.com/archives/fedora-package-announce/2009-August/msg00597.html
- https://www.redhat.com/archives/fedora-package-announce/2009-August/msg00608.html
- https://www.redhat.com/archives/fedora-package-announce/2009-July/msg00632.html
- https://www.redhat.com/archives/fedora-package-announce/2009-July/msg00676.html
- http://corelabs.coresecurity.com/index.php?action=view&type=advisory&name=WordPress_Privileges_Unchecked
Get alerted when CVE-2009-2335 or the next vulnerability affects your stack