What’s Vulnerable › Vulnerabilities
CVE-2009-2620
- Severity: medium (CVSS 5.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-07-29 · updated 2026-06-16
- Weakness: CWE-20
Description
src/remote/server.cpp in fbserver.exe in Firebird SQL 1.5 before 1.5.6, 2.0 before 2.0.6, 2.1 before 2.1.3, and 2.5 before 2.5 Beta 2 allows remote attackers to cause a denial of service (daemon crash) via a malformed op_connect_request message that triggers an infinite loop or NULL pointer dereference.
Affected products
- FirebirdSQL firebird: from 1.5 before 1.5.6; from 2.0.0 before 2.0.6; from 2.1 before 2.1.3; 2.5.0, 2.5.0-alpha1, 2.5.0-beta1 — fixed in 1.5.6, 2.0.6, 2.1.3
How to fix
Upgrade to a fixed version: FirebirdSQL firebird 1.5.6, 2.0.6, 2.1.3. Check the vendor advisory for mitigations.
References
- http://tracker.firebirdsql.org/browse/CORE-2563
- http://www.coresecurity.com/content/firebird-sql-dos
- http://www.exploit-db.com/exploits/9295
- http://www.securityfocus.com/bid/35842
- https://bugzilla.redhat.com/show_bug.cgi?id=514463
- https://www.redhat.com/archives/fedora-package-announce/2009-August/msg01341.html
- https://www.redhat.com/archives/fedora-package-announce/2009-August/msg01370.html
- http://tracker.firebirdsql.org/browse/CORE-2563
- http://www.coresecurity.com/content/firebird-sql-dos
- http://www.exploit-db.com/exploits/9295
- http://www.securityfocus.com/bid/35842
- https://bugzilla.redhat.com/show_bug.cgi?id=514463
Get alerted when CVE-2009-2620 or the next vulnerability affects your stack