What’s Vulnerable › Vulnerabilities

CVE-2009-2629

Description

Buffer underflow in src/http/ngx_http_parse.c in nginx 0.1.0 through 0.5.37, 0.6.x before 0.6.39, 0.7.x before 0.7.62, and 0.8.x before 0.8.15 allows remote attackers to execute arbitrary code via crafted HTTP requests.

Affected products

How to fix

Upgrade to a fixed version: nginx 0.5.38, 0.6.39, 0.7.62, 0.8.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2009-2629 or the next vulnerability affects your stack