What’s Vulnerable › Vulnerabilities
CVE-2009-2687
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-08-05 · updated 2026-06-16
- Weakness: CWE-20
Description
The exif_read_data function in the Exif module in PHP before 5.2.10 allows remote attackers to cause a denial of service (crash) via a malformed JPEG image with invalid offset fields, a different issue than CVE-2005-3353.
Affected products
- Debian Linux: 4.0, 5.0, 6.0
- PHP: before 5.2.10 — fixed in 5.2.10
How to fix
Upgrade to a fixed version: PHP 5.2.10. Check the vendor advisory for mitigations.
References
- http://bugs.php.net/bug.php?id=48378
- http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00004.html
- http://marc.info/?l=bugtraq&m=127680701405735&w=2
- http://osvdb.org/55222
- http://secunia.com/advisories/35441
- http://secunia.com/advisories/36462
- http://secunia.com/advisories/37482
- http://secunia.com/advisories/40262
- http://www.debian.org/security/2009/dsa-1940
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:145
- http://www.mandriva.com/security/advisories?name=MDVSA-2009:167
- http://www.php.net/releases/5_2_10.php
Get alerted when CVE-2009-2687 or the next vulnerability affects your stack