What’s Vulnerable › Vulnerabilities
CVE-2009-2698
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2009-08-27 · updated 2026-06-16
- Weakness: CWE-476
Description
The udp_sendmsg function in the UDP implementation in (1) net/ipv4/udp.c and (2) net/ipv6/udp.c in the Linux kernel before 2.6.19 allows local users to gain privileges or cause a denial of service (NULL pointer dereference and system crash) via vectors involving the MSG_MORE flag and a UDP socket.
Affected products
- Canonical Ubuntu Linux: 6.06, 8.04, 8.10, 9.04 (and their updates)
- Fedoraproject Fedora: 10 (and their updates)
- Linux kernel: before 2.6.19 — fixed in 2.6.19
- RedHat Enterprise Linux Desktop: 4.0, 5.0 (and their updates)
- RedHat Enterprise Linux Eus: 4.8, 5.3 (and their updates)
- RedHat Enterprise Linux Server: 4.0, 5.0 (and their updates)
- RedHat Enterprise Linux Server Aus: 5.3 (and their updates)
- RedHat Enterprise Linux Workstation: 4.0, 5.0 (and their updates)
- SUSE Linux Enterprise Server 15 SP1: 10-sp2
- SUSE Linux Enterprise Server: 10-sp2; 9 (and their updates)
- VMware ESXi: 4.0 (and their updates)
- VMware vCenter Server: 4.0
How to fix
Upgrade to a fixed version: Linux kernel 2.6.19. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=1e0c14f49d6b393179f423abbac47f85618d3d46
- http://lists.opensuse.org/opensuse-security-announce/2009-08/msg00008.html
- http://rhn.redhat.com/errata/RHSA-2009-1222.html
- http://rhn.redhat.com/errata/RHSA-2009-1223.html
- http://secunia.com/advisories/23073
- http://secunia.com/advisories/36430
- http://secunia.com/advisories/36510
- http://secunia.com/advisories/37105
- http://secunia.com/advisories/37298
- http://secunia.com/advisories/37471
- http://support.avaya.com/css/P8/documents/100067254
- http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.19
Get alerted when CVE-2009-2698 or the next vulnerability affects your stack